
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20190701092905
template: 
currentrequest: /apps/pbcs.dll/article?avis=LA&date=20190701&category=BUSINESS&lopenr=190709998&Ref=AR
currentrequestunmodified: /business/20190701/test-drive-2019-toyota-sequoia-4x4
@templatetype: /apps/pbcs.dll/article?avis=LA&date=20190701&category=BUSINESS&lopenr=190709998&Ref=AR
@pagetype: article
app version: 2.0.349
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Bastrop Daily Enterprise - Bastrop, LA" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script>
docReady(function()
{ ims.startServices(); }
);
</script>
<!-- Meta Tags - Global Article6 guid: 8C9FD852-406D-7D7C-E053-0100007F45EA-->
<meta name="description" content="Entry price: $49,050Price as tested: $69,303This week we&#x2019;re driving the 2019 Toyota Sequoia, which receives a nice new grill and headlight upgrade. Our 4x4 tester came in top flight Platinum dress making this fully loaded, three-ton SUV quite the vehicle with every conceivable amenity listed as standard fare. Sequoia first appeared in 2000 and is built in Princeton, Indiana.Sequoia underwent a complete refresh in 2008 and has always delivered massive room and towing capacity for those" />
<meta name="news_keywords" content="greg zyla" />
<script type="text/javascript">var news_keywords=["greg zyla"];</script>
<meta property="vf:unique_id" content="siteLA-pub288-8C9FD852-406D-7D7C-E053-0100007F45EA">
<meta property="fb:app_id" content="127847170640220"/>
<meta property="tout:article:id" content="art-8C9FD852-406D-7D7C-E053-0100007F45EA-pub288">
<meta property="bt:pubDate" content="20190701T08:50:32Z">
<meta property="bt:modDate" content="20190701T08:54:00Z">
<meta property="bt:keywords" content="greg-zyla">
<meta property="bt:author" content="Greg Zyla More Content Now">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.bastropenterprise.com/storyimage/LA/20190701/BUSINESS/190709998/AR/0/AR-190709998.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.bastropenterprise.com/storyimage/LA/20190701/BUSINESS/190709998/AR/0/AR-190709998.jpg">
	<meta property="og:image:width" content="1440">
	<meta property="og:image:height" content="810">
<meta name="twitter:title" content="Test Drive: 2019 Toyota Sequoia 4x4">
<meta name="twitter:description" content="Entry price: $49,050Price as tested: $69,303This week we&#x2019;re driving the 2019 Toyota Sequoia, which receives a nice new grill and headlight upgrade. Our 4x4 tester came in top flight Platinum dress making this fully loaded, three-ton SUV quite the vehicle with every conceivable amenity listed as standard fare. Sequoia first appeared in 2000 and is built in Princeton, Indiana.Sequoia underwent a complete refresh in 2008 and has always delivered massive room and towing capacity for those">
<meta property="og:title" content="Test Drive: 2019 Toyota Sequoia 4x4"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Entry price: $49,050Price as tested: $69,303This week we&#x2019;re driving the 2019 Toyota Sequoia, which receives a nice new grill and headlight upgrade. " />
<meta name="author" content="Greg Zyla More Content Now">
<link rel="canonical" href="https://www.bastropenterprise.com/business/20190701/test-drive-2019-toyota-sequoia-4x4"/>
<script type="text/javascript">var dfp_url = "8C9FD852-406D-7D7C-E053-0100007F45EA";</script>
<link rel="amphtml" href="https://www.bastropenterprise.com/business/20190701/test-drive-2019-toyota-sequoia-4x4?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.bastropenterprise.com/business/20190701/test-drive-2019-toyota-sequoia-4x4"
	},
    "headline": "Test Drive: 2019 Toyota Sequoia 4x4",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.bastropenterprise.com/storyimage/LA/20190701/BUSINESS/190709998/AR/0/AR-190709998.jpg",
       	"height": 810,
       	"width": 1440
    },
    "url": "https://www.bastropenterprise.com/article/20190701/BUSINESS/190709998",
    "thumbnailUrl": "https://www.bastropenterprise.com/apps/pbcsi.dll/bilde?Site=LA&Date=20190701&Category=BUSINESS&ArtNo=190709998&Ref=AR",
    "dateCreated": "20190701T14:50:32Z",
    "datePublished": "20190701T14:50:32Z",
    "dateModified": "20190701T14:54:00Z",
    "author": [{"@type":"Person","name":"Greg Zyla More Content Now"}],
    "creator": "Greg Zyla More Content Now",
    "publisher": {
       "@type": "Organization",
       "name": "Bastrop Daily Enterprise - Bastrop, LA",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.bastropenterprise.com/Global/images/head/nameplate/la-bastrop_logo.png"
       }
    },
    "articleSection": "Business",
    "keywords": ["greg-zyla"],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	}
  }
</script>

		<title> Test Drive: 2019 Toyota Sequoia 4x4 - Business - Bastrop Daily Enterprise - Bastrop, LA - Bastrop, LA</title>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.350/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
    /*==== ARTICLE ======*/
    	#interstitial {line-height: 0;}
    	.ad-300x150{
	    	width: 300px;
	    	max-height: 150px;
    	}
    	.articleInjectAd{
	    	display: none;
    	}
    	.native-injected{
	    	height: 0px;
    	}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	/* Buzz widget */
    	#gh-slider-buzz > div > div > figure > a > div.image.unveil-loaded{
			min-height: 112px;
			box-shadow: 0px 0px 5px 0px rgba(50, 50, 50, 0.75);
			border-radius: 2px;
    	}
    	#gh-slider-buzz{
    		font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
    	}
    	#gh-slider-buzz h3 > span{
    		font-weight: bold;
			font-size: 14.4px;
			color:rgb(68, 68, 68);
			text-decoration-color:rgb(68, 68, 68);
			line-height: 16px;
    	}
    	#gh-slider-buzz h3 > span:hover{
			text-decoration: underline;
    	}
    	#gh-slider-buzz .dateline{
			font-size: 10px;
			color:rgb(153, 153, 153);
			text-decoration-color:rgb(153, 153, 153);
    	}
    	#gh-slider-buzz .gh-slider-caption h3{
	    	max-height: 500px;
    	}
    	#gh-slider-buzz div.nophoto > a > h3{
	    	margin-bottom: 5px;
    	}
    	#gh-slider-buzz div.nophoto{
	    	padding:0px;
    	}
    	#gh-slider-buzz span.summary{
	    	font-size: 11px;
		    max-height: 140px;
		    display: block;
		    line-height: 14px;
		    overflow: hidden;
    	}
    	#gh-slider-buzz .slick-slider,#buzz-widget-mobile .section-ribbon,#buzz-widget .section-ribbon{
	    	margin-bottom: 0px;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
				<script type="text/javascript">
  var TriggerPrompt = function(articleUrl, contentId) {
	if (!$(".p402_premium").length) {
		setTimeout(function(){ TriggerPrompt(articleUrl, contentId) }, 500);
		return;
	}
    var ARTICLE_URL = articleUrl ? articleUrl : window.location.href,
		CONTENT_ID 	= contentId ? contentId : 'everything',
		el 			= document.createElement('script'),
		url 		= '//survey.g.doubleclick.net/survey?site=_zvttm5lvgowaeyme5wyjza2y7u' +
              '&url=' + encodeURIComponent(ARTICLE_URL) +
              (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
              '&random=' + (new Date).getTime() +
              '&after=1';
    el.setAttribute('src', url);
    var head = document.getElementsByTagName('head')[0] ||
        document.getElementsByTagName('body')[0];
    head.appendChild(el);
  };
  function pressplusAlternateAction() {
	__gh__webApp.paywall.showUserLoginForm();
  }
</script>

					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.bastropenterprise.com/news" target="_top">News</a></li><li><a href="https://www.bastropenterprise.com/sports" target="_top">Sports</a></li><li><a href="https://www.bastropenterprise.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.bastropenterprise.com/lifestyle" target="_top">Life</a></li><li><a href="http://www.legacy.com/obituaries/bastropenterprise/" target="_blank">Obits</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/LaBas" target="_blank">Classifieds</a></li><li><a href="https://www.bastropenterprise.com/homes" target="_top">Homes</a></li><li><a href="https://www.bastropenterprise.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.bastropenterprise.com/jobs" target="_top">Jobs</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.bastropenterprise.com/subscribenow?g2i_source=bastropenterprise.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=LBDE&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-login">
					<a class="hide" data-gh-paywall-event="login" href="/login">
						<i class="fa fa-user"></i>
						<span class="hidden-sm hidden-xs">Log in</span>
					</a>
				</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bastropenterprise.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.bastropenterprise.com">
							<img class="mainheadnameplate" src="https://www.bastropenterprise.com/Global/images/head/nameplate/la-bastrop_logo.png"  alt="Bastrop Daily Enterprise - Bastrop, LA" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.bastropenterprise.com/subscribenow?g2i_source=bastropenterprise.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bastropenterprise.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bastropenterprise.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20190701085455">
	<div class="inner">
		<h1 class="headline">Test Drive: 2019 Toyota Sequoia 4x4</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.bastropenterprise.com/storyimage/LA/20190701/BUSINESS/190709998/AR/0/AR-190709998.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">2019 Toyota Sequoia 4x4 [Toyota]</div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					Greg Zyla More Content Now
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Monday</h3>
							<span class="article-meta-date">Jul&nbsp;1,&nbsp;2019&nbsp;at&nbsp;8:50&nbsp;AM</span>
							<span class="article-meta-updated">Jul&nbsp;1,&nbsp;2019&nbsp;at&nbsp;8:54&nbsp;AM</span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p>Entry price: $49,050<br>Price as tested: $69,303<br><br>This week we&#x2019;re driving the 2019 Toyota Sequoia, which receives a nice new grill and headlight upgrade. Our 4x4 tester came in top flight Platinum dress making this fully loaded, three-ton SUV quite the vehicle with every conceivable amenity listed as standard fare. Sequoia first appeared in 2000 and is built in Princeton, Indiana.<br><br>Sequoia underwent a complete refresh in 2008 and has always delivered massive room and towing capacity for those who need or desire this type of vehicle. It&#x2019;s not good on gas by any means, (13 city and 17 highway), but after two longer trips during our week-long test I guarantee you&#x2019;ll feel like &#x201c;King of the Road&#x201d; traveling the nation&#x2019;s highways.<br><br>Sequoia is the biggest SUV Toyota offers. It is 10-inches longer in wheelbase than the Toyota Land Cruiser and 12.1-inches longer than the Highlander. And even though you are totally aware of Sequoia&#x2019;s mass while driving, the SUV delivers outstanding comfort and then doubles as a 7,000-pound tow capacity vehicle.<br><br>Unlike most other SUVs that are built on a car like uni-body platform, Sequoia still sits on a full chassis underneath similar but not identical to the heavy-duty full-size Tundra pickup. The major differences are Sequoia&#x2019;s rear suspension featuring double wishbones with coil springs for improved ride comfort and a Torsen brand 4x4 locking multi-mode center differential.<br><br>Available in four trims, Sequoia 4x4 starts at the eight-passenger SR5 at $52,275, then moves upward to a TRD trim at $54,990, Limited at $60,770, and top line Platinum for $67,635. Rear drive-only Sequoia models start at $49,050 in the SR5 trim only. Platinum trims are seven-passenger designs thanks to second row Captain chairs.<br><br>The Sequoia Platinum features wood interior trim, adaptive smart cruise, perforated heated and cooled leather seats and a great sounding JBL audio system. An enhanced Entune infotainment with Navigation system is also notable. Additionally, every 2019 Sequoia receives Toyota&#x2019;s renowned Safety Sense and Star Safety System.<br><br>The Platinum also features 20-inch Dunlop Sport 5000 tires on aluminum alloy  wheels, new design chrome grille, three-zone climate control, special Platinum badges, beautiful leather interior, power seats, power reclining second row seats, power reclining and fold flat third row (very nice). Also standard is a rear seat BluRay movie system with a 9-inch screen. As tested, our Sequoia Platinum came in at a final $69,303 with $373 for a carpeted floor mat and door sill protector option and $1,295 delivery.  <br><br>All 2019 Sequoias arrive with enhanced LED headlamps, auto windshield wipers, some new colors and a few more tweaks over the 2018 model. Other than that, and especially if you tow a boat, camper or classic car, it&#x2019;s the Sequoia we&#x2019;ve come to appreciate over the years as the &#x201c;big bruiser&#x201d; of SUVs. Additionally, you still use a key to start this beauty, which in the land of push button start vehicles is a welcome nostalgic touch.<br><br>Under the hood sits Sequoia&#x2019;s 5.7-liter V8 that produces 381 horses and 401 lb. ft. of torque. Coupled to a heavy duty six speed automatic with tow/haul modes, our 4x4 model was very peppy when asked for more power. All things considered, the aforementioned 17 highway MPG is pretty decent for a vehicle of this size. Always remember when you get into heavy, truck like vehicle that can tow 7,000 pounds, big engines are necessary and will always require more fuel to move aggressively.   <br><br>Fuel mileage aside, there are many Sequoia positives. From a safety aspect, riding around in a Sequoia offers built-in security from size/mass alone. When you add the standard Toyota Safety Sense-P features, I pity anything smaller than a bus that plows into a Sequoia.  <br><br>Toyota Safety Sense-P includes Pre-Collision System with Pedestrian Detection, Lane Departure Alert with Sway Warning System, Automatic High Beams and Dynamic Radar Cruise Control. But Sequoia goes another step forward, as the standard Star Safety System adds Vehicle Stability Control, Traction Control, Anti-lock Brakes, Electronic brake-force Distribution, Brake Assist, and Smart Stop Technology at speeds greater than 5 mph. So, when combined with three tons of mass and all this safety, you are traveling nestled in one of the safest SUVs ever built.<br><br>Underneath, a fully independent suspension with a 4x4 multi-mode unit with locking differential is noteworthy allowing secure footing during inclement weather. Other notable standard features include power slide moonroof, three zone climate control, 6.1-inch touch screen with Bluetooth, USB, the latest high-tech goodies, towing upgrades with tow/haul modes and trailer brake connection, rear safety camera, blind spot and much more. Platinum models also feature an adaptive suspension to keep everything level.<br><br>Important numbers include a wheelbase of 122-inches, 6,000-lb. curb weight, from 18.9 to 120.1 cu. ft. of cargo space, 38.1 ft. turn circle, 26.4 gallon fuel tank and 9.6-inch ground clearance.<br><br>All of this leads to value, as the Sequoia 4x4 is quite a buy starting at just $52,275 versus smaller, albeit top luxury, Toyota Land Cruiser and its $85,165 entry. Being that the Land Cruiser is built to compete with Range Rover and Cadillac Escalade, those who opt for a Sequoia can pocket over $35,000 difference and still travel in  luxury.  <br> <br>Your Toyota dealer awaits your visit to explain all trims and models in the Toyota SUV/Crossover family. And, as we&#x2019;re already into July of the 2019 model year, there may be some impressive dealer incentives for prospective consumers to ponder.   <br><br>Likes: Very roomy, powerful V8, extremely safe, great for towing.<br>Dislikes: Fuel mileage, dated design, two-wheel drive only in SR5 trim.<br>Greg Zyla writes weekly on cars for More Content Now and GateHouse Media.</p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.bastropenterprise.com/subscribenow?g2i_source=bastropenterprise.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
					<h2>Sign up for daily e-mails</h2>
					<a href="http://myprofile.bastropenterprise.com/">
						<button type="button" class="btn btn-subscribe">
							Sign up
						</button>
					</a>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.bastropenterprise.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTAO_BE" target="_top">My Profile</a></li><li><a href="https://www.bastropenterprise.com/contact" target="_top">Contact Us</a></li><li><a href="http://bastropenterprise.mycapture.com/mycapture/index.asp" target="_blank">Purchase Photos</a></li><li><a href="http://ezads.bastropenterprise.com" target="_blank">Place an Ad</a></li><li><a href="http://www.bit.ly/1JEsBzv" target="_blank">Church Directory</a></li><li><a href="http://shoppingmall.bastropenterprise.com/ROP/Categories.aspx" target="_blank">Special Sections</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://mediakit.gatehousemedia.com/Bastrop_LA" target="_top">Advertise With Us</a></li><li><a href="http://shoppingmall.bastropenterprise.com/ROP/Categories.aspx" target="_blank">Shopping Mall</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/LaBas" target="_blank">Classifieds</a></li><li><a href="https://www.bastropenterprise.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.bastropenterprise.com/homes" target="_top">Real Estate</a></li><li><a href="https://bastroppennysaver.classifieds.totallylocal.com/" target="_blank">Penny Saver</a></li><li><a href="https://www.bastropenterprise.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.bastroplacoc.org/" target="_blank">Bastrop Chamber of Commerce</a></li><li><a href="http://www.morehouseedc.org/" target="_blank">MEDC</a></li><li><a href="http://www.cityofbastrop.com/" target="_blank">City of Bastrop</a></li><li><a href="http://www.visitmorehouse.com/" target="_blank">Morehouse</a></li><li><a href="http://www.mpso.net/" target="_blank">Morehouse Sheriff's Office</a></li><li><a href="http://www.mpsb.us/" target="_blank">Morehouse Schools</a></li></ul></div><div class="footer-col"><h4>Other La. Publications<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.deridderdailynews.com" target="_blank">Beauregard Daily News</a></li><li><a href="http://www.donaldsonvillechief.com" target="_blank">Donaldsonville Chief</a></li><li><a href="http://www.weeklycitizen.com" target="_blank">Weekly Citizen</a></li><li><a href="http://www.leesvilledailyleader.com" target="_blank">Leesville Daily Leader</a></li><li><a href="http://www.postsouth.com" target="_blank">Post South</a></li><li><a href="http://www.sulphurdailynews.com" target="_blank">Southwest Daily News</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=LA&date=20190701&category=BUSINESS&lopenr=190709998&Ref=AR -->
			<div id="footer-main-copyright">
											<p id="footer-copyrightInfo">&copy; Copyright 2006-2019 <a href="http://www.gatehousemedia.com/about-us/" target="_blank">GateHouse Media, LLC.</a> All rights reserved&nbsp;&nbsp;&bull;&nbsp;&nbsp;GateHouse Business</p>
							<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
							<br />Bastrop Daily Enterprise - Bastrop, LA  ~ 119 East Hickory, Bastrop, LA 71220 ~ <a href="http://www.gatehousemedia.com/privacy-policy/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gatehousemedia.com/terms_of_use/" target="_blank">Terms Of Service</a></p>
							<script>document.getElementById('footer-main-copyright').getElementsByTagName('p')[1].innerHTML += '<a href="/ownership"><img id="footer-main-gh-logo" src="//cdn.gatehousemedia.com/gh-sites/global/images/logo/ghlogo_horizontal.png" alt="Gatehouse Media Logo"></a>'</script>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.bastropenterprise.com/subscribenow?g2i_source=bastropenterprise.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.bastropenterprise.com" target="_top">Home</a></li><li><a href="https://www.bastropenterprise.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"886"><a href="https://www.bastropenterprise.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"887"><a href="https://www.bastropenterprise.com/news/court-news" target="_top">Courts</a></li><li id="navLink-TEST-"888"><a href="https://www.bastropenterprise.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"889"><a href="https://www.bastropenterprise.com/nown" target="_top">NOWN</a></li><li id="navLink-TEST-"890"><a href="https://www.bastropenterprise.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"891"><a href="https://www.bastropenterprise.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"36072"><a href="https://www.bastropenterprise.com/news/nation-world" target="_top">Nation & World</a></li><li id="navLink-TEST-"36071"><a href="https://www.bastropenterprise.com/news/shareable" target="_top">Shareable</a></li><li id="navLink-TEST-"36073"><a href="http://elections.gatehousemedia.com/bastropenterprise/todaystopics/" target="_blank">Election 2016</a></li></ul></li><li><a href="https://www.bastropenterprise.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"894"><a href="https://www.bastropenterprise.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.bastropenterprise.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"897"><a href="https://www.bastropenterprise.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"898"><a href="https://www.bastropenterprise.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"899"><a href="https://www.bastropenterprise.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"900"><a href="https://www.bastropenterprise.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"877"><a href="https://www.bastropenterprise.com/entertainment/tv-guide" target="_top">TV Guide</a></li><li id="navLink-TEST-"38360"><a href="https://www.bastropenterprise.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.bastropenterprise.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52181"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"904"><a href="https://www.bastropenterprise.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"905"><a href="https://www.bastropenterprise.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"906"><a href="https://www.bastropenterprise.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"907"><a href="https://www.bastropenterprise.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"908"><a href="https://www.bastropenterprise.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"909"><a href="https://www.bastropenterprise.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"910"><a href="https://www.bastropenterprise.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"911"><a href="https://www.bastropenterprise.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.bastropenterprise.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"914"><a href="https://www.bastropenterprise.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"915"><a href="https://www.bastropenterprise.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"916"><a href="https://www.bastropenterprise.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.bastropenterprise.com/business-news" target="_top">Business</a></li><li><a href="http://www.legacy.com/obituaries/bastropenterprise/" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.bastropenterprise.com/photos" target="_top">Photos</a></li><li><a href="https://www.bastropenterprise.com/videos" target="_top">Videos</a></li><li><a href="https://www.bastropenterprise.com/calendar" target="_top">Calendar</a></li><li><a href="http://games.bastropenterprise.com" target="_top">Games</a></li><li><a href="https://www.bastropenterprise.com/contests" target="_top">Contests</a></li><li><a href="https://www.bastropenterprise.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.bastropenterprise.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.bastropenterprise.com/section/promoted//?prx_adpz=2227" target="_top">From Our Advertisers</a></li><li><a href="https://www.bastropenterprise.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.bastropenterprise.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTAO_BE" target="_top">My Profile</a></li><li><a href="https://www.bastropenterprise.com/subscribenow" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.marketplaceadsonline.com/marketplace/LaBas" target="_blank">Classifieds</a></li><li><a href="http://mediakit.gatehousemedia.com/Bastrop_LA" target="_top">Advertise With Us</a></li><li><a href="http://findnsave.bastropenterprise.com/" target="_top">Find-N-Save</a></li><li><a href="https://www.bastropenterprise.com/section/cars" target="_blank">Cars</a></li><li><a href="https://www.bastropenterprise.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.bastropenterprise.com/homes" target="_top">Homes</a></li><li><a href="http://ezads.bastropenterprise.com" target="_blank">Place an Ad</a></li><li><a href="https://www.bastropenterprise.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://bastropenterprise.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:deetubbs@bastropenterprise.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/terms_of_use/">Terms of Use</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/privacy-policy/">Privacy Policy</a>
		</li>		
		<li>
			<a href="http://www.gatehousemedia.com/our-markets/">GateHouse Media Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bastropenterprise.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/BastropEnterprise""
								target="_blank"
								title="Bastrop Daily Enterprise - Bastrop, LA Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="Bastrop Daily Enterprise - Bastrop, LA RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.bastropenterprise.com/contact"
								title="Contact Bastrop Daily Enterprise - Bastrop, LA">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
        <a href="http://bastropenterprise.com/subscribe" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.bastropenterprise.com/apps/pbcs.dll/article?avis=LA&date=20190701&category=BUSINESS&lopenr=190709998&Ref=AR"}'>
            Learn More
        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.350/app.min.js" crossorigin="anonymous"></script>
		<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
		<script>
		function __gh__init() {
			var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
		<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2019-07-01&nbsp;16:50:57-->
	</body>
</html>